Apache > Lucene

Apache Lucene - System Requirements

System Requirements

Lucene Java has the following minimum requirements:

  • Java 1.5.x or greater.
  • ANT 1.7.0 or greater.
  • CPU, Disk and Memory requirements are based on the many choices made in implementing Lucene (document size, number of documents, and number of hits retrieved to name a few.)

Contrib modules may have other requirements, refer to their documentation and build files for information.